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《遥感原理与应用课程设计》指导书 

 

一、课程设计的目的 

1、加深理解和巩固理论课上所学的有关遥感的基本原理、遥感传感器的成像

机理、遥感图像的处理方法、专题信息提取以及遥感综合应用技术； 

2、锻炼自主编程设计遥感图像处理算法和熟练运用遥感软件独立分析问题、

解决具体问题的实际工作能力； 

3、培养良好的工作习惯和科学素养，为今后参加科学研究工作以及毕业设计

打下良好的基础。 

二、课程设计的任务 

1、针对遥感影像数据，设计从遥感影像上进行专题信息提取与专题图制作的

总体方案、具体方法与详细流程步骤。此任务以个人为单位进行； 

2、利用遥感图像处理软件完成“遥感专题信息提取与专题图制作”的成果实

现。此任务以个人为单位进行； 

3、用 VC 对遥感原理中所涉及的图像处理主要算法，按专题进行自主编程设

计，也可自拟设计项目经指导教师同意后进行编程设计。此任务以 2 人为一组进

行，每小组任选一专题，专题如下： 

专题 1 

    对灰度图、彩色图颜色值进行线性拉伸的算法实现 

    显示灰度图，彩色图颜色值直方图的算法实现 

对灰度图，彩色图进行直方图均衡的算法实现 

专题 2 

    对彩色图进行任意角度旋转的算法实现 

    对彩色图进行缩小放大的算法实现 

    对彩色图进行平移的算法实现 

专题 3 

    对灰度图进行均值滤波（3*3、5*5、7*7）的算法实现 

    对灰度图进行中值滤波 （3*3、5*5、7*7）的算法实现 

    对灰度图进行高斯平滑的算法实现 
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    对灰度图进行梯度锐化的算法实现 

专题 4 

    对灰度图用不同算子进行边缘检测的算法实现 

    Sobel 算子、Robert 算子、Prewit 算子、Laplace 算子       

    Krisch 算子、Canny 算子 

专题 5 

    图像色彩空间变换（RGB->HIS、HIS->RGB)的算法实现 

    彩色图像灰度化的算法实现 

专题 6 形态学处理 

    腐蚀（水平、垂直、全方向）、膨胀（水平、垂直、全方向）的算法实现； 

    开运算（先腐蚀后膨胀）、闭运算（先膨胀后腐蚀）的编程实现。 

专题 7 植被指数和变化检测 

    植被指数的算法原理与程序设计 

    变化检测的算法原理与程序设计  

专题 8 基于多项式几何纠正 

    纠正多项式系数解算、纠正变换函数建立、坐标转换、灰度重采样的算

法原理与编程实现 

专题 9 影像镶嵌： 

    镶嵌影像边界计算 

    镶嵌影像像素值计算（重叠区域、非重叠区域） 

    亮度、反差调正以及边界线平滑 

专题 10 影像融合 

    空间域非加权融合算法原理与成编程实现 

    空间域加权融合的算法原理与编程实现 

    HIS 变换融合的算法原理与编程实现 

专题 11K 均值法分类： 

    初始聚类中心的选取 

    最近距离准则逐像素初始分类； 

    新聚类中心计算与分类； 

    迭代终止条件设定，分类结果输出 
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专题 12 基于 ISODATA 法的聚类分析 

    初始聚类中心的选取 

    最近距离准则逐像素初始分类 

    类的分裂与合并 

    新类中心的计算与分类 

    迭代运算的控制 

    分类结果的输出 

专题 13 小波变换 

三、课程设计的方式 

1、教师提供课程设计的遥感图像处理软件（ERDAS）和实习数据； 

2、学生根据课程设计任务完成“遥感专题信息提取与专题图制作”的总体方

案设计与流程框图设计，交给教师审核； 

3、利用 ERDAS 软件完成“遥感专题信息提取与专题图制作”的成果实现；

在具体操作中有疑问提倡先独立思考、后询问教师、再归纳总结的方法； 

4、对每一步骤的实现方法进行归纳总结，找出其中的难点和关键点，并对每

一步处理的效果进行评估，找出影响效果的因素和提高效果的方法； 

5、利用 VC 完成算法的设计和实现，编程中出现疑难可采取查阅资料、相互

讨论、询问教师的方法，不得互相抄袭、拷贝。 

四、课程设计的安排 

 

单元 内容 

1 

教师讲解课程设计的任务安排，学生学习任务书、熟悉 ERDAS 软件主菜单中每个

大模块的主要功能，重点看 Viewer、Import、DataPrep、Interpreter、Classifier、

Modeler 六个模块的在线帮助，弄清楚它们的功能含义，完成方案设计和流程框图 

2 
教师审核课程设计方案并集中讲解“遥感专题信息提取与专题图制作”的主要步骤

和流程，学生阅读指导书、掌握遥感数据处理的相关操作 

3-7  ERDAS 软件实现专题信息提取 

整理实习成果：对每一步骤的实现方法进行归纳总结，找出其中的难点和关键点，

并对每一步处理的效果进行评估，找出影响效果的因素和提高效果的方法 

撰写课程设计报告 
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8-13 自主设计编程实现遥感图像处理算法 

14 分班级成果验收答辩 

五、课程设计的成果 

1、“遥感专题信息提取与专题图制作”的总体方案与流程框图； 

2、ERDAS 软件完成的“遥感专题信息提取与专题图制作”专题图； 

3、ERDAS 软件完成“遥感专题信息提取与专题图制作”的设计报告，按课

程设计内容：数据准备（格式转换、波段叠加）、影像增强、几何纠正、影像镶

嵌、影像融合、影像分类及分类后处理、专题图制作，分别叙述并附关键成果图。 

设计报告按以下格式撰写： 

1）课程设计的目的和意义 

2）课程设计的原理和方法 

3）课程设计的过程和步骤 

4）课程设计的结果分析与评价 

5）课程设计的总结与体会 

4、VC 编程实现算法设计的程序代码； 

5、VC 编程实现遥感图像处理算法的设计报告，设计报告按科技论文格式撰

写。 

六、课程设计的要求 

1、每个学生都应在教师指导下独立完成或小组分工协作完成。提倡交流、讨

论，严禁抄袭、拷贝等现象。课程设计完成后每个学生制作 PPT 并进行个人答

辩，个人答辩情况将计入成绩； 

2、严格按课程设计安排课表时间准时到达实验室，不得随意旷课、迟到、早

退。主动维护好实验室硬软件，保持实验室卫生。 

七、课程设计的考核 

1、ERDAS 软件部分（40%） 

2、算法自主设计编程与答辩（50%） 

3、平时考勤（10%） 

八、参考书目 

[1] 《VisualC++数字图像获取、处理及其实践应用》，人民邮电出版社，杨枝
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灵等，2003 年 1 月； 

[2] 《遥感原理与应用》，孙家柄等，武汉大学出版社，2003 年； 

[3] 《遥感原理与应用课程设计》指导书。
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《遥感原理与应用课程设计》实习说明 
 

ERDAS IMAGINE 是美国 ERDAS 公司开发的专业遥感图像处理与地理信息系统软件。它

以模块化的方式提供给用户，使得用户可根据自己的应用程序的要求、资金情况合理地选择

不同功能模块及其不同组合，对系统进行剪裁，充分利用软硬件资源，并最大限度地满足用

户的专业应用要求。 

ERDAS IMAGINE 面向不同需求的用户，对于系统的扩展功能采用开放的体系结构以

IMAGINE Essentials、IMAGINE Advantage、IMAGINE Professional 的形式为用户提供了低、

中、高三档产品架构，并有丰富的功能扩展模块供用户选择，使产品模块的组合具有极大的

灵活性。 

在图像处理方面，直观的操作步骤使用户操作起来非常灵活方便。IMAGINE 的窗口提供

了卷帘、闪烁、设置透明度以及根据坐标进行窗口关联功能，方便多个相关图像的比较。

ERDAS IMAGINE 为不同的应用提供了 250 多种地图投影系统，还有非常方便的坐标转换工

具。新开发的专家分类器，为高光谱、高分辨率图像的快速高精度分类提供了可能。此工具

突破了传统分类只能利用光谱信息的局限，可以利用空间信息辅助分类。 

ERDAS IMAGINE 图标面板的功能如下表所示： 

 

图  标 命  令 功  能 

 

IMAGINE  Credits 查阅 ERDAS 信用卡 

 

Start IMAGINE Viewer 打开 IMAGINE 视窗 

 

Import / Export 启动数据输入输出模块 

 

Data Preparation 启动数据预处理模块 

 

Map Composer 启动专题制图模块 

 

Image Interpreter 启动图像解译模块 

 

Image Catalog 
启动图像库管理模块 

 

Image Classification 
启动图像分类器 

 

Spatial Modeler 
启动空间建模工具 
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Radar  
启动雷达图像处理模块 

 

Vector 
启动矢量功能模块 

 

Virtual GIS 
启动虚拟 GIS 模块 

 

一、视窗操作 

本节在了解视窗菜单、工具等各项功能的基础上，重点学习掌握以下内容： 

 图像文件的显示及缩放功能 

 两幅图像的叠加（混合、卷帘、闪烁）操作 

 如何修改图像的头信息 

 单点、矩形区域光标查询功能 

  AOI 菜单及工具板操作 

 栅格图像的常用处理 

1．视窗功能简介 

二维视窗（Viewer）是显示栅格图像、矢量图形、注记文件、AOI（Area  Of  Interest 感兴趣的

区域）等数据层的窗口。ERDAS IMAGINE 软件有三种途径打开一个新视窗： 

 ERDAS 图标面板菜单栏：Main → Start IMAGINE Viewer…→  

 ERDAS 图标面板工具栏：点击图标   →   

 在视窗  的文件下拉菜单选 ： File → New → Viewe →  

 

1）视窗菜单命令及功能（略，见文件菜单操作） 

2）视窗工具栏命令及功能 

图  

标 
命  令 功  能 

图  

标 
命  令 功  能 

 Open Layer 打开文件  
Measure Points,lines 

and Areas 

量测点、线、

面 
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 Close Top Layer 关闭最顶层文件  
Start/Update Inquine 

Cursor 

启动光标查

询功能 

 
Show Info 

For Top Layer 

显示最顶层文件

信息 
 

Show Tool Palette for 

Top Layer 

显示对应顶

层文件的工

具菜单 

 
Save Top Non-AOI 

Layer 

保 存 最 顶 层 非

AOI 文件  Start Profile Tools 
启动剖面线

工具 

 
Print Contents of 

Viewer 
打印视窗文件 

 
Reset Window Tools 

Zoom 、 Roam

按钮复位 

 
Remove Contents 

From Viewer 

关闭视窗所有文

件 
 Zoom in By Two 

以点为中心

放大两倍显

示 

 Reset Zoom 
恢复 Zoom 操作前

的影像显示 
 Zoom out By Two 

以点为中心

缩小两倍显

示 

 Zoom in By Two 
以视窗为中心放

大两倍显示  Roam Image 图像漫游 

 Zoom out By Two 
以视窗为中心缩

小两倍显示 

   

 

2．文件菜单操作 

1）文件菜单命令及功能 

一级菜

单命令 

二级菜

单命令 
三 级 菜 单 命 令 功   能 

File   文件操作 

 New  产生新文件 

  AOI  Layer 

Vector  Layer 

Annotation  Layer 

Viewer 

Viewer  Specified 

Map Composition 

创建 AOI 层 

创建矢量数据层 

创建注记层 

打开一个新视窗 

产生视窗模式 

产生地图编辑 

 Open  打开文件 

  AOI  Layer … 

Raster Layer … 

Vector Layer … 

Annotation Layer … 

TerraModel Layer … 

View … 

Map Composition… 

打开 AOI 层（.aoi） 

打开影像层(.img) 

打开矢量数据层(Arc  coverage) 

打开注记层(.ovr) 

打开地形模型层(.pro) 

打开视窗文件 (.vue) 

打开地图(.map) 
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Three Layer Arrangement … 

Multi  Layer Arrangement … 

打开三波段影像层(.img) 

打开多波段影像层(.img) 

 Save  保存文件 

  Top  Layer 

Top  Layer  As … 

AOI  Layer  As… 

All   Layers 

View… 

以当前文件名保存视窗中的最上层文件 

以其它文件名另存视窗中的最上层文件 

另存 AOI 文件 

保存当前视窗中的所有层的文件 

将当前视窗内容存为后缀是.vue 的文件 

  View   to   Image File … 将当前视窗内容转换存为.img 的文件 

  Print… 打印当前视窗内容 

  Clear 清除当前视窗内容 

  Close 关闭当前视窗 

  Close Other Viewers 关闭当前视窗以外的其它视窗 

 

2）装载显示影像(.img) 

 点击视窗下拉菜单 File → Open → Raster Layer → Select Layer To Add 对话框 

 点击视窗工具栏图标   → Select Layer To Add 对话框 

在 Select Layer To Add 对话框中有 File 和 Raster Option 两个选项，其中： 

 File → Look in (指定所装影像文件的目录) →  File Name (指定所装影像文件名) → File of Type (指定所

装影像文件类型)  

 File → Recent (如果所装影像是近期操作过的文件，前面三项不做，直接由此项功能选择)  

 Go To (改变文件的路径) 

 Raster Option （设置显示图像文件的各项参数）→ Display as (装多波段图像选择 Ture Color 项、 装假彩

色图像选择 Pseudo Color 项、灰度图像选择 Gray Scale 、地形图数据选择 Relief) →Layers to Colors：(装多

波段图像时设置图像彩色合成颜色) →Clear Display（清除 / 不清除视窗中已有信息开关）→ Fit to Frame（按

照视窗大小缩放 / 不缩放显示影像开关）→ Data Scaling (图像拉伸/ 不拉伸开关)等 ； 

 

3．实用菜单操作 

1）实用菜单命令及功能 

一级 

菜单 

命令 

二级 

菜单 

命令 

三级 

菜单 

命令 

功    能 

Utility     实用操作 

 Inquire Cursor…  用十字鼠标定位查询坐标 

 Inquire Box…  定义一个矩形框并显示其坐标范围 

 Inquire Color…  定义十字鼠标或矩形框的颜色 

 Inquire Shape…  定义鼠标指针的形状 

 Inquire Home  将鼠标指针移动到当前图像显示窗口的中心 

 Measure… 

 

 用鼠标在图上量测,包括点的坐标、直线的长

度、多边形、矩形和圆、椭圆的周长和面积。 
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 Selector  Properties… 

 

 改变Inquire Cursor 或 Inquire  Box的颜色

和坐标。 

 Pick Properties…  在创建一个多边形或折线时生成 Poly Edit 

对话框，通过键盘输入改变坐标。 

 Blend…  混合两个影像图层。 

 Swipe…  通过水平或垂直逐行切换的卷帘方式在上下

两个图像之间转换。 

 Flicker…  在上下两个图层之间切换,与SWIPE不同的是,

切换是瞬间闪烁的,而不是逐行切换。 

 Layer Info…  显示当前视窗中最上面图层的信息。 

 HFA  Info…  显示影像的分层数据结构。 

 Image  Drape…  打开 Image  Drape 对话框显示 DEM 数据。 

 VirtualGIS…  三维地形的虚拟漫游。 

2）图像信息显示 

本操作主要应用于查阅或修改图像文件的有关信息，如投影信息、统计信息、显示信息等。调用此功

能有三种途径： 

 ERDAS 面板中主菜单 → Tools → Image Information → Image info 对话框（无文件名） 

 在本视窗中单击菜单条：Utility → Layer Info…→ Image info 对话框 

 在本视窗中单击工具图标：  → Image info 对话框 

Image info 对话框如下图所示： 

 

 

 

在实际工作中，经常需要用 Image info 对话框中的 Edit 菜单命令修改或添加图像的头文件信息，

包括地理坐标信息即图像的左上角 X、Y 坐标，像元值的大小、单位和地图投影信息，其修改地理坐标信

息和地图投影信息的操作过程为： 

   Edit → Change Map Model → Change Map Info 对话框 → Upper Left X、Y（修改图像的左上角

X、Y 坐标）→ Pixel Size X、Y（像元值的大小）→Units（单位）→ Projection （投影类型）→ OK

（确认地图坐标改变） 

  Edit → Add / Change Projection → Projection Chooser 对话框 → Standard（标准投影模式）→ 
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Categories（选择投影类型）→ Projection（自动确定投影参数）→ Custom （用户投影模式）→ 

Projection Type（投影类型：以 UTM 为例）→ Spheroid Name （椭球体参数名称：Krasovsky） → 

Datum Name （基准面名称：Underfind）→ UTM Zone（UTM 带号）→ NORTH or SOUTH （北

半球或南半球）→ North → OK（确认投影信息改变） 

 

4．显示菜单操作（菜单命令及功能） 

一级 

菜单 

命令 

二级菜单命令 三级菜单命令 功    能 

View Arrange Layers…  显示排列图像对话框 

 Create Magnifier …  产生一个放大窗口 

 Tile Viewers   并排平铺多个视窗 

 Window Information…  显示当前窗口的信息 

 
Split… （略） 

垂直、水平分割窗口为两个或自定

义多个大小相同窗口  

 Zoom  （略） 窗口按照倍数缩放 

 Scale   以任意比例缩放显示 

 

 

Image To Window   

Window to  Image 

Extent… 

Scale Tool… 

重新设置影像尺寸以适应窗口尺寸 

重新设置窗口尺寸以适应影像尺寸 

定义显示范围 

定义比例尺 

 Rotate …  任意角度旋转显示影像 

 
Rotate/Flip/Stretch…  

缩放、平移、任意角度旋转、镜像

反转、拉伸显示影像等 

 North Arrow  打开/关闭指北针 

 Scale Bar  打开/关闭比例尺条 

 Virtual Roaming  打开/关闭虚拟漫游 

 Link/Unlink Viewers （略） 连接/断开连接影像窗口 

 Background  color…  改变窗口的背景色 

 Status Bar  打开/关闭窗口的底部显示状态条 

 Scroll Bars  打开/关闭下拉式菜单 

 Menu Bar  打开/关闭视窗滚动条 

 Tool Bar  打开/关闭工具栏 

 Borders  打开/关闭视窗标题栏 

5．AOI 菜单操作 

AOI 是用户感兴趣区域（Area  Of  Interest）的缩写，确定一个 AOI 之后，可以使相关的处理操作

对 AOI 内的象元进行，AOI区域可以保存为一个文件，便于在以后的多个场合调用(如：用于分幅裁剪图像、

专题信息提取等)，AOI 区域经常应用于图像分类模板(signature)文件的定义。 

一级 

菜单 

命令 

二级菜单命令 三级菜单命令 功    能 

AOI   感兴趣区域（Area  Of  Interest） 

 Tools  打开 AOI 工具面板 

 Undo  取消编辑操作 
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 Cut  剪切 AOI 区域 

 Delete Raster Masker  删除栅格掩膜 

 Group  建立 AOI 组合 

 Ungroup  取消 AOI 组合 

 Reshape  改变 AOI 形状 

 Invert Polygon  选择 AOI 区域以外的要素 

 Element Properties  AOI 要素特性（周长、面积） 

 Styles  AOI 显示特性（线型粗细、间隔设置） 

 Seed Properties  AOI 种子特征 

 Copy Selection to AOI  依据 AOI 拷贝选择要素 

 Link  建立视窗 AOI 连接 

 Tablet Input  数字化仪输入 

  New Configuration 建立新的数字化仪配置 

  Current Configuration 调用已配置的数字化仪 

 

6．栅格菜单操作 

栅格菜单操作包含了栅格工具等 20 项命令，可以对栅格图像数据进行多种处理或属性设置。 

1）栅格菜单命令及功能 

一级 

菜单 

命令 

二级菜单命令 三级菜单命令 功    能 

Raster    

 Tools  打开 Rastr 工具面板 

r Undo  取消编辑操作（可以多次取消） 

 Copy  复制所选择的栅格区域 

 Paste  粘贴所选择的栅格区域 

 Band Combination  图像波段彩色合成调整 

 Pixel Transparency  像元透明显示设置 

 Set Resampling 

Method 
 图像重采样方法设置 

 Data Scaling   图像拉伸数值调整 

 Contrast  图像反差调整 

 

 

Histogram Equalize 

Standard Deviation 

Stretch 

General Contrast… 

Brightness / 

Contrast… 

Piecewise Contrast… 

Breakpoints… 

Load Breakpoints… 

Save Breakpoints… 

直方图均衡化处理 

标准差拉伸处理 

通用反差调整 

亮度/反差调整 

分段反差调整 

直方图断点处理 

加载直方图断点 

保存直方图断点 

 Filtering  图像滤波处理 

  Smooth 平滑 
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Sharpen 

Find Edges 

Convolution Filtering.. 

Statistical Filtering.. 

锐化 

边缘提取 

卷积滤波 

均值滤波 

 Recode  图像分类重编码 

 Fill  图像数值填充 

 Offset Value  图像数值位移 

 Interpolate  图像插值处理 

 Recompute Statistics   图象待征重新统计 

 Attributies  栅格属性编辑器 

 Geometric 

Correction 
 图像几何校正 

 Set Drop Point  图像坐标平移 

 Profile Tools  图像剖面工具 

 Relief Shading 

Tools 
 地势阴影工具 

2）图像反差调整(直方图断点操作) 

   视窗菜单条：Raster → Contrast →Breakpoints →Breakpoint Editor 对话框, 显示如下不同波段的直

方图： 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

用下列直方图断点编辑工具对上述各波段直方图进行编辑: 

 插入断点（Insett Breaks） 

 删除断点(Cut  Breakpoints) 

 左断点曲线(Left-Right Curve) 

 右断点曲线(Right-Left Curve) 

 用虚线显示断点前的曲线 

 通过鼠标移动对直方图做线性变换 
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 打开查找表 

 将查找表变化应用于图像 

 

 

二、 数据输入输出 

 

本节在了解各种数据格式的基础上，重点学习掌握以下内容： 

 普通二进制格式的图像数据输入 

 TIFF 格式的图像数据输入输出 

ERDAS 的数据输入输出功能（IMPORT/EXPORT），可以进行多种数据格式的输入输出转换。目前，

IMAGINE 8.4 可以输入的数据格式达 70 多种，可以输出的数据格式近 30 种，几乎包括常用或常见的栅格

数据和矢量数据格式，具体的数据格式见 IMAGINE 输入输出对话框中的列表，一般操作过程如下： 

在 ERDAS 图标面板菜单条中选：Main    Import/Export 或者直接点击图标   ， 即可看到输

入输出对话框如下图： 

 

  

 

 首先确定是输入数据（Import）还是输出数据（Export） 

 在列表中选择输入数据或输出数据的类型（Type：Generic Binary 、TIFF） 

 在列表中选择输入数据或输出数据的媒体（Media：CD-ROM、Tape、File） 

 确定输入数据的文件路径和文件名（Input File：*.dat、*.tif 或*.img） 

 确定输出数据的文件路径和文件名（Output File：*.img 或*.dat、*.tif） 

 OK ! 

则计算机自动将你的输入/输出文件格式转化为你要的输出/输入文件格式。 

 

三、数据预处理 

本节在了解各种数据预处理方法的基础上，重点学习掌握以下内容： 

图像分幅裁剪 

图像几何校正 

图像拼接处理 
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数据预处理模块由一组实用的图像数据处理工具构成，包括生成单值图像、三维地形表面、图像分幅

裁剪、图像几何校正、图像拼接处理、非监督分类、图像投影等，主要是根据工作区域的地理特征和专题

信息提取的客观需要，对数据输入模块中获取的 IMG图像文件进行范围调整、误差校正、坐标转换等处理，

以便进一步开展图像解译、专题分类等分析研究。 

 

1．启动数据预处理模块 

ERDAS IMAGINE 软件有两种途径启动数据预处理模块： 

 ERDAS 图标面板菜单栏：Main →Data Preparation..→Data Preparation 菜单： 

 ERDAS 图标面板工具栏：点击图标   →  Data Preparation 菜单： 

 

2．图像分幅裁剪(Subset Image) 

 Subset Image → Subset Image 对话框  

1）规则分幅裁剪 

规则分幅裁剪是指裁剪图像的边界范围是一个矩形,有三种方式定义裁剪范围： 

直接在 Subset 对话框中定义左上角和右下角的坐标 

应用查询框，即在 Viewer 模块打开所要裁剪的图像并定义一个 Inquire Box。 

应用感兴趣区域（AOI）首先在 Viewer 中打开被裁剪图像并绘制矩形 AOI，然后在 Subset Image 对话框中

选择点击 AOI 按钮打开 AOI 对话框，并确定 AOI区域来自图像视窗即可。 

2）不规则分幅裁剪 

不规则分幅裁剪是指裁剪图像的边界范围是个任意多边形，有 AOI 多边形裁剪和 ARC/INFO 多边形裁

剪两种。运用 AOI 多边形裁剪时需首先在 Viewer 视窗中绘制打开 AOI 多边形；运用 ARC/INFO 多边形裁剪

时，首先将 ARC/INFO 多边形转换为栅格数据，然后通过掩膜运算(Mask)实现不规则裁剪。 

 

3、几何纠正 

(1) 点 击 图 标                打开 View # 1、View # 2； 

(2)主菜单 Session / Tile Viewers（平铺视窗窗口）； 

(3)将主菜单最小化； 

(4)在 View # 1 中导入未纠正影像: 

   File→ Open →Raster layer...(柵格层) → 选路径 

  或者: 激活工具图标 →  
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(5)在 View # 2 中导入已纠正的影像 

     激活工具图标  

(6) 启动地面控制点编辑器：Raster → Geometric Correction； 

(7)选择多项式拟合： Polynomial  → OK； 

(8)选择多项式系数进行计算, → Close； 

(9)选择纠正方式：比如 O Existing Viewer  → OK； 

(10)系统提示已纠正的影像的参数信息: 

                        Projection (地图投影为)  

Spheroid (椭球体参数)   

                        UTM    (武汉幅带号)    

    → OK； 

(11)对照未纠正影像和已纠正影像，用刺点器  寻 找同名控制点： 

 

如果用一次项系数计算，至少找四个控制点，为了便于剔除粗差较大的点及检查，可选 7-8 个控制

点、5 个检查点（请思考：如果用二次项、三次项或者更高次项系数计算，应选多少个控制点？），要求

控制点均匀分布，最好布在图廓四周，中间内插几个点，总的中误差控制在 1个像元内，满足精度要求后，

做下一步重采样； 

(12) a．选路径 D:\给输出文件名 

     b．重采样方法: 邻  元  法 

                    双线性内插     任选一种 

                    双三次卷积 

(13) 在输出像元大小 Output Cell Sizes 处修改重采样像元大小，TM 影像每个像素为 30 米； 

(14) 重采样完毕，在 Viewer # 5 中装入你已纠正好的影像与 Viewer # 2 中的参考影像，用视窗关联的

功能进行比较检验。  

4、图像拼接处理 

(1) 在主菜单上点击图标     模块； 

(2) 选 择 镶 嵌 影 像 Mosaic Images... 

(3) 在 Mosaic Tool # 1 窗口中点击 → Display Add Images Dialog；               

(4) 选择参与镶嵌的原始影像 

(5) 在 Mosaic Tool # 1 窗口中点击 → Set Mode for Input  Images； 

(6) 在 Mosaic Tool # 1 窗口中点击按钮→ Display Image  Matching Options Dialog； 

     做左右两幅影像的反差调整: 

        选 ● All images 

        选 ● Band by Band 

(7) 在 Mosaic Tool # 1 窗口中点击按钮 →  Set Mode for Intersections； 

(8) 在 Mosaic Tool # 1 窗口中点击按钮  → Set Overlap Function； 



17  

      做左右两幅影像重叠区的处理: 

      选   ⊙ No Cutline Exists 

      选   ⊙ Feather (平滑过渡) 

(9) 在 Mosaic Tool # 1 窗口中 → process → Run Mosaic→在对话框中给输出文件名 → OK→生成一

幅镶嵌好的成果图。 

(10) 最后对以上的成果进行分析，总结本人在实习中的收获与存在的问题或不足，找出问题的原因，并提

出解决的方法与步骤。 

 

四、 图像解译 

本节在了解各种图像解译方法的基础上，重点学习掌握以下内容： 

图像空间增强 

部分实用功能（多个波段叠加组合或拆分） 

ERDAS  IMAGINE 的图像解译器（Image Interpreter）包含了 50 多个用于遥感图像处理的功能模块。

启动图像解译模块有两种途径： 

 ERDAS 图标面板菜单栏：Main →Image Interpreter…→Image Interpreter 对话框： 

 ERDAS 图标面板工具栏：点击图标   → Image Interpreter 菜单： 

 

1、空间增强 

(1) 在视窗中导入未增强的原始影像 

                             直方图均衡 

                             方差调整 

      通用反差调整 

   (2) Raster / Contrast       亮度 / 反差调整 

                             分段拉伸 

                             直方图断点处理 

                                                                                                                         

                                               直方图均衡 

                                               方差调整 

(3)  Raster / Contrast / General Contrast       高斯调整                                                                                                

                                               线性拉伸 

非线性拉伸 

 

                                 平滑 

锐化 

(4)    Raster / Filtering        边缘提取 
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                                 卷积滤波 

                                 均值滤波 

把每种增强方法都做几遍，进行比较，体会一下各种方法的不同效果，不明白的地方查阅软件的在线

帮助。 

2、波段叠加和波段拆分 

 多个单波段叠加组合和多波段拆分单波段过程如下： 

 Image Interpreter 菜单 Utilities… → Layer Stack 菜单 → Layer Selection Stacking 对话框 → Input 

File(选择要合成的图像文件名 1) → Layer (选择层数或 All)→ Add → Input File(选择要合成的图像

2) → Layer (选择层数或 All)→Add → Input File(选择要合成的图像 3) →Layer (选择层数或 All)→ 

Add(一直重复选择完要合成的图像为止) → Output File (输出组合后的文件名) → OK! 

 Image Interpreter 菜单 Utilities… → Layer Stack 菜单 → Layer Selection Stacking 对话框→ Input 

File(选择要拆分的多波段图像文件名) → Layer (选择要拆分的层数) → Add → Output File (输出

拆分后的文件名) → OK! 

    

 

五、图像分类 

本节在了解图像分类方法的基础上，重点学习掌握以下内容： 

监督分类 

非监督分类 

图像分类是基于图像像元的数据文件值，将像元归并成有限几种类型、等级或数据集的过程。常规图

像分类主要有三种方法：非监督分类、监督分类、专家分类。启动图像分类器主要有两种途径（在数据预

处理模块也可调用非监督分类对话框）： 

 ERDAS图标面板菜单栏：Main →Image Classification →Classification 菜单 

 ERDAS 图标面板工具栏：点击图标   →Classification 菜单 

监督法分类步骤: 

（1） 导入待分类处理的影像 

 

（2）启动分类器 Classifier  → signature  Editor(特征 定义编辑器)； 

 

（3）在视窗中点击 AOI (中文意思为感兴趣的区域，此时出现一个 AOI 工具模块) 

→ 点击工具模块中任意多边形按钮                    

  

（4）在不同的类别中分别画训练样区(用左键单击画，然后用右键双击结束)； 

（5）然后在特征定义编辑器 signature  Editor 中的对话框中点→编辑菜单 Edit → Add 将画的训练样

区加到特征定义编辑器中，此时编辑器中增加了该训练样区的一些信息，如训练样区的名字、颜色、

总像元数以及统计信息最大值、最小值、均值、标准偏差等等； 

（6）重复 4，5直至将类别的训练样区都画完； 
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（7） 在 signature  Editor(特征定义编辑器)的对话框中点 Evaluate（评价）→ Contingency (计算混

淆矩阵),混淆严重，精度受影响，重新修改训练样区直至满意为止； 

（8）在signature  Editor(特征定义编辑器)的对话框中→Classify(分类) → Supervised (监督法分类) 

→ 在 Output File 处给输出文件名 → 点击 Attribute Options... → Close →用缺省的最大似

然法分类（或最小距离法） → OK。 

（9）再打开一个视窗，将分类的影像与原始影像叠加在同一个视窗中用户混合、卷帘、闪烁的方式或者

用掩模透明度的方式进行目视对照比较：在视窗中点击菜单 Utility→Blend(混合方式或者 Swipe

卷帘、Flicker 闪烁)或者在视窗中点击菜单 Raster → Attributes„→修改分类图的透明度

Opacity 的值。 

非监督法分类步骤： 

（1）在signature  Editor(特征定义编辑器)的对话框中激活→Classify(分类) → Unsupervised ...(非

监督法分类) → 在 Output File 处给输出文件名 → 在 Number of classes→ Color Scheme 

Options„(打开分类后的颜色设置功能菜单) → 选中Grayscale (则分类出来的影像为灰度值的黑

白影像，需要做下一个步骤赋颜色值，如果) → 选中 Approximate True Color (则分类出来的影

像颜色接近待分类处理的影像合成的颜色，如果对分类的颜色还不满意，也可用到下一个步骤修改

颜色值) → Maximum Iterations: 6 (表示程序循环 6 次) → Convergence Threshold 处用缺省

值 0.950 →OK. 

（2）再打开一个视窗,将分类后的黑白影像或彩色影像装进来在视窗中激活 → Attributes„（赋颜色值

或者修改颜色值），然后与监督法分类的影像进行比较。 

 

六、专题信息提取 

 

（1）在主菜单上点击图标          模块； 

（2）选择 GIS Analysis…→ Recode…(分类重编码) → 在 Input File 打开分类影像 →在 Output File 处给

分类重编码后的影像定义一个输出文件名 →  Setup Recode…(打开分类重编码对话框，进行类别合

并) → OK(关闭分类重编码对话框) → OK。 

（3）打开视窗显示分类重编码后的影像。 

 

七、遥感专题地图制作 

专题地图是突出反映一种或几种主体要素的地图，这些主体要素多是根据专门用途的需要确定

的，它们应表达得很详细，其它的地理要素则根据表达主体的需要作为地理基础迭绘。根据研究需要

和制图区域的特征生成图层、文本、比例尺、图例、公里格网线、符号、图廓线等图像整饰内容并生

成制图文件。 

 


